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1. INTRODUCTION 

AASI is an application for simulating the energy spectra of alpha particles. It uses a Monte Carlo 

method to produce artificial alpha spectra, enabling convenient studying of the phenomena and the 

different factors that affect the spectrum quality.  

 

It is recommended to start by taking a look at one or more of the examples provided with AASI. 

Feel free to skip directly to the section 4. Tasks & examples, and go through the Example 1 to get 

an immediate feel to the use of this program.  

2. KEY FEATURES 

 AASI offers a broad range of features to simulate alpha spectra in various situations: 

 

 Alpha detector properties. The properties of the alpha detector can be taken into account to 

simulate measurements made with a specific detector model. See section 3.2.2 The alpha 

detector properties for details. 

 

 Radiation source properties. Different type of radiation sources with user-specified nuclide 

composition can be taken into account. See section 3.3.3 The radiation source properties for 

details 

 

 Material between the detector and source. Different layers of absorbing materials may be 

defined. See section 3.4.1 Absorbing layers for details 

 

 Coincidence and backscattering studying. Coincidences between the alpha particles and 

electrons / x-rays can be taken into account for simulating the spectra. See section 3.5.1 

Backscattering and Coincidences for details 

 

 Type of simulation. Geometric detection efficiency in addition to the energy spectra may be 

calculated. See section 3.5.2 Geometric efficiency calculation for details. 

 

 Plotting and visualisation. The simulation results, i.e. the alpha particle energy spectra can 

be instantly plotted and further saved into file or printed. See section 3.7.1 Displaying alpha 

spectra in the plot page for details. 

3. THE INTERFACE 

The different aspects concerning alpha radiation are grouped into pages that contain the respective 

features. When editing the values of the parameters in the numeric fields, remember to press enter 

to make sure the changes are applied. 
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3.1. The welcome page 

 
 

The welcome page is the first thing you will see when you start AASI for the first time (and 

subsequent times, unless you disable it). The welcome page contains version information, as well as 

controls that allow you to open example simulations included with AASI. You may control the 

behaviour of the welcome page using the following controls: 

 

’Do not display this page again’ checkbox 

 

When checked this option prevents the welcome page from 

being displayed when you start AASI. If you later change 

your mind, you may open the welcome screen using the 

Help → Show welcome page menu item. You may then 

uncheck the box and the welcome page will be displayed 

when you start the application. 

Close welcome page button 

 

Closes the welcome page. If closed, you may open the 

welcome page using the Help → Show welcome page menu 

item. 

 

To open an example file, use the buttons next to the example descriptions. For more information 

about the examples, see section 4. Tasks & examples. 
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3.2. The detector page 

 
 

Here you can edit the detector properties as well as manage detector files. It is important to note 

that each simulation is associated with a detector, whose properties can be saved and loaded 

independently from the rest of the parameters. This page contains only a single window. 

3.2.1. Loading and saving detector files 

The detector properties are described in a separate file and you can save and load them using the 

user interface. The detector files should be saved using the extension .det,  to avoid confusion 

with file types, although this is not strictly necessary. 

Important: When a simulation is saved, a reference to the detector used with the simulation is also saved. When a 

saved simulation is opened, AASI will look for the corresponding detector in the same location as the opened 

simulation and, failing that, in the detectors subdirectory of your AASI directory. The final fallback will be the 

file Detector.det in AASI/bin directory, it will be used when all else fails. 

 

The detector management is handled by two buttons: 

Open detector button 

 

Loads detector properties from a file. Pressing the 

button pops up a file selection dialog from which the 

desired detector file can be selected. 

Save detector button 

 

Saves the detector properties into a file. Pressing the 

button pops up a file selection dialog which can be used 

to specify the file name. 

3.2.2. The alpha detector properties 

Detector properties have an effect on the alpha particle peak shape. In this window the detector 

properties are characterised. Once you have determined the properties of your detector, and 
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saved the to a file, you do not need to modify them later in subsequent simulations. The 

properties of the detector are divided into groups: 

 

General properties 

 

Diameter 

 

The diameter of the active detector volume. Alpha 

particles emitted from the source are registered as 

pulses by the detector when they enter this volume. 

Resolution 

 

The detector  Full Width at Half Maximum, is defined 

in here as the width of the gaussian part of the detector 

response. The total response is a convolution of the 

gaussian and exponential parts. 

Thickness 

 

The thickness of the active volume of the detector. The 

active volume means the volume that is actually able to 

detect incoming alpha particles. 

Dead layer thickness 

 

The thickness of the dead layer of the detector. The dead 

layer is a thin layer of material on the surface of the 

detector that does not register incoming alpha particles. 

The dead layer contributes to the energy loss of the 

alpha particles. (See, however, page 24). 
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Peak shape properties 

 

Total tailing  

 

The total amount of peak tailing to apply (0 = 

none, 1= full). This parameter allows 

regulation of how much tailing is desired in the 

simulation. If full tailing is used, all pulses 

registered by the detector are distributed 

according to the exponential and Gaussian 

parts of the detector response. 

Fast component 

 

Used to specify the so-called “fast” component 

(the component that decreases rapidly) of the 

triple exponential tail by giving the mean of 

the first of the three exponential envelopes. 

Intermediate component 

 

Used to specify the so-called “intermediate” 

component (the component that decreases with 

intermediate speed) of the triple exponential 

tail by giving the mean of the second of the 

three exponential envelopes.  

Slow component 

 

Used to specify the so-called “slow” 

component (the component that decreases 

slowly) of the triple exponential tail by giving 

the mean of the last of the three exponential 

envelopes.  

Fast / Intermediate area ratio 

 

This area ratio is used to specify the ratio 

between the areas of the fast and intermediate 

exponential components. This property can be 

used to fine tune the tailing effects together 

with the slow, intermediate and fast 

component properties. 

Slow / Intermediate 

 

Area ratio is used to specify the ratio between 

the areas of the slow and intermediate 

exponential components. This property can be 

used to fine tune the tailing effects together 

with the slow, intermediate and fast 

component properties. 
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Dead layer properties 

 

Dead layer material list 

 

The dead layer material list allows you to select the 

material of the dead layer of the detector. The dead layer 

contributes to the energy-loss of an incoming alpha 

particle. 

Dead layer material mass number 

 

Used to specify an isotope of the material selected in the 

dead layer material list. 

 

Other properties 

 

Detector type 

 

Detector type is a user-specified descriptive text that 

characterises the detector. E.g. 450 PIPS could mean 

that PIPS detector is used with an area of 450 mm
2
. 

3.3. The source page 

 

By source we mean the alpha emitting radionuclides specified by the user and the material in 

which they are contained. The source is composed of materials (not necessarily the same elements 

as the radionuclides) in which the alpha particle energy loss occurs. Example: Source material 

may be UO2, but the alpha particle energy deposition is calculated only for the radionuclides 

selected by the user from the nuclide list, e.g. 
239

Pu, meaning that 
239

Pu nuclides are present in 

UO2 matrix. 

Specifying the radiation source consists of defining the alpha particle emitting radionuclides 

present in the source and how they are distributed in the source matrix. For example, aerosol 
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particles containing alpha particle emitting radionuclides on their surface (such as radon progeny) 

may be distributed in an air filter composed of stable material.  

The simulation can be done either by specifying the energy of the alpha particles emitted from the 

source, or by using library data on radionuclides. 

3.3.1. Specifying the alpha particle energy 

Sometimes it may be useful to assume that the source emits alpha particles of given energy i.e. 

no specific radionuclides are selected for the simulations. This can be done using the following 

controls. Note, however, that in this case the coincidence and backscattering features are 

unavailable.  

 

'The source emits alpha particles of energy' button 

 

Selects an alpha emitter that emits 

alpha particles of given energy to be 

simulated.  
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Selecting the 'The source emits alpha particles of energy' button enables the following controls: 

 

'The emitted energy' field  

 
Sets the energy in MeV of the alpha particles emitted from the 

source. Values are required to be > 0. 

'The number of decays' field  

 
Sets the number of decays, i.e. the number of alpha 

particles emitted to simulate. Values are required to be > 

0. 

3.3.2. Specifying the alpha particle emitting nuclide 

AASI includes an extensive library of data on alpha particle emitting radionuclides, based on 

the ENSDF database. To simulate a source with specific nuclides as the alpha emitters, use the 

following controls: 

 

'Select alpha particle emitting radionuclide from list' button 

 

Selects a nuclide to be used  as the 

alpha emitter. Selecting this option 

enables further options allowing you 

to choose the nuclides and the 

library to use.  

 

Selecting this option allows you to choose the alpha emitter from a list of radionuclides and 

enables the following controls: 

The 'open library' button  

 

The open library button allows you to open a nuclide 

library from which to select the nuclides for 

simulation. Pressing this button will open a file 

chooser dialog from which you may choose the 

appropriate library. The nuclides in the library will 

then be displayed in the nuclide selection list.  

 

 AASI uses two libraries:  

 NuclideLibrary.xml - the basic library with 

data on the most important alpha-emitting 

radionuclides. This library is based on the 

ENSDF radionuclide data. 

 PuCoincidences.xml - a special library with 

additional data needed for the coincidence and 

backscattering calculations. 
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The nuclide selection list  

 

The nuclide selection list allows you to select a 

nuclide from currenly loaded nuclide library (the 

name of the library is displayed above). Once the 

nuclide is selected, information about it will be 

displayed below, and it may be moved to the selection 

using the  add nuclide to selection button. 

The 'add nuclide to selection' button  

 

The add nuclide to selection button adds the nuclide selected in 

the nuclide selection list into the nuclides selected for simulation 

table. The nuclide is now set as an alpha emitter in the source for 

the simulation. 

 

 

 

The 'remove nuclide from selection' button  

 

The remove nuclide from selection button removes the nuclide 

selected in the nuclides selected for simulation table.  

The 'nuclides selected for simulation' table  

 

The nuclides selected for simulation table displays the 

nuclides that will be used in the simulation. For each 

nuclide to be used, a name and number of decays is 

displayed. You can specify the number of decays for 

each nuclide as desired, values are required to be > 0. If 

the nuclide has coincidence data, its name will be 

displayed in blue color. 

The nuclide info view  

 

The nuclide info view displays information about the 

nuclide selected currently in the nuclide selection list. 

Half life, natural abundance and alpha lines are shown. 
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3.3.3. The source properties 

The distance of the source from the detector and the source type are given here. You can 

define whether the emitters are in a homogeneous source, in particles of known properties or 

in particles embedded in a source matrix. 

 

To specify the distance of the source from the detector use the following control: 

The 'source-detector distance' field 

 
Specifies the distance of the source from the detector. 

The distance is measured from the top surface of the 

source (or the highest point in case of convex / 

concave sources). 

 

To select how the alpha emitters are distributed in the source use the following controls: 

The 'homogeneous source type' button 

 

The alpha particle emitters are 

homogeneously distributed into a 

source matrix.  

The 'radioactive particles source type' button 

 

The alpha particle emitting material 

is in the form of radioactive 

particles.  

The 'radioactive particles in homogeneous source matrix type' button 

 

The alpha particle emitting 

radionuclides are present in particles 

of known properties. In addition, 

these particles are embedded in a 

homogeneous matrix. 
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3.3.3.1. Homogeneous source 

 

In this source type the alpha particle emitters are homogeneously distributed in the source 

matrix of following properties: 

The source diameter 

 

The source is assumed to be cylindrical in 

shape, and this is the diameter of the 

cylinder. 

Central thickness 

 

The thickness of the source at its center. This 

can be used together with the side thickness 

to specify a source that has convex or 

concave upper surface (the surface facing 

the detector).  When central thickness is 

modified, side thickness is automatically set 

to match.  

Side thickness 

 

The thickness of the source at its side. This 

can be used together with the central 

thickness to specify a source that has convex 

of concave upper surface (the surface facing 

the detector) 

Thickness fluctuation 

 

Standard deviation of normally distributed 

thickness fluctuation.   

Density 

 

The density of the source material.  

 

The source material can be defined using the following controls: 

'Source element composition' table 

 

This table displays the elemental composition of the source. By 

clicking on the white area of table you are able to edit the 

material. See section 3.7 editing materials with the material 

editor. 
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3.3.3.2. Radioactive particles 

 

In this type of source the alpha particle emitters are distributed in particles of different 

properties. You have several options to control the type of particles to be used in the 

simulations:  

Particle occurrence defines how particles are located on the sample: 

'Single particle' button 

 

The location of the single radioactive particle can be 

edited with the two fields for x and y - coordinates. 

The origin of the coordinate system coincides with 

the symmetry axis of the detector. 

 
Important: This option disables the lognormal size 

distribution. 

'Many particles' button 

 

Radioactive particles are randomly distributed into 

the deposition area whose diameter is given by the 

user. 

 

Particle type defines the shape of the particles and how alpha emitters are distributed within 

them. 

'Spherical particle type' button 

 

Spherical shape is used for the homogeneous particle(s).  

'Ellipsoidal particle type' button 

 

Ellipsoidal shape is used for the homogeneous particle(s) 

simulated.  
Important: This option disables the use of a lognormal size distribution. All 

particles are considered to have the same size instead. 

'Spherical surface layer type' button 

 

Radioactive material is distributed on the surface of 

spherical particles. 

 

Particle size defines the size of the particles used in the simulation. 

Important: This option is not available when the single particle option is used 

'All particles have the same size' button 

 

All particles have the same size defined in an item available 

in the particle properties. 
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'Lognormally distributed particle size' button 

 

Parameters of the lognormal distribution are given in an 

item available in particle properties. 

 

The lognormal distribution of the particle sizes is 

characterised by mean diameter and geometric standard 

deviation. A property for constraining the maximum size 

of the particles is also used to prevent the improbable and 

undesirable cases of extremely large particles. 

 

The number of decays for each generated particle is 

assumed to be proportional to the mass of the particle. 

 
Important: This option is not available if single particle or ellipsoidal 

particle type are selected 

 

Particle properties defines the properties of the particles based on the occurrence, type and 

size options mentioned above. It is important to realize that not all properties are available 

with all combinations of options. For instance specifying a lognormal size distribution 

obviously excludes the particle size property but presents the parameters of the distribution for 

editing instead. 

Particle diameter  

 The diameter of the particle(s) to simulate.  
Only available with spherical particle type. 

Particle X diameter  

 The diameter of the particle(s) along the X -

 axis. 
Only available with ellipsoidal particle type. 

Particle Y diameter  

 The diameter of the particle(s) along the Y -

 axis. 
Only available with ellipsoidal particle type. 

Particle Z diameter  

 The diameter of the particle(s) along the Z - 

axis. This is the axis that points towards the 

detector. 
Only available with ellipsoidal particle type. 

Mean diameter  

 The count mean diameter of the particle(s). 

Values must be >= 0.2 µm 
Only available with lognormal size distribution 

Geometric standard deviation  

 The geometric standard deviation of the  

diameter.  
Only available with lognormal size distribution 
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Diameter ceiling  

 The maximum diameter of the particle(s). 
Only available with lognormal size distribution 

Particle density  

 Density of the particles.         

 

The particle material can be defined using the following controls: 

'Particle element composition' table  

 

This table displays the elemental composition of the particles. 

By clicking on the white portion of table you will be able to edit 

the material. See section 3.7 editing materials with the material 

editor. 
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3.3.3.3. Radioactive particles in a homogeneous matrix 

 

In this type of source, the alpha particle emitting particles are distributed in a homogeneous 

source matrix. When this type of source is selected, you must define both the particle and the 

source matrix properties. 

 

For the particles the procedure is similar to the option of radioactive particles. Except that: 

 Single particle simulation is not supported in this scheme 

 Since the particles are now embedded in the source matrix, it is possible to define how 

the particles have penetrated the matrix. Use the following controls: 

'Uniform depth distribution' button  

 

Specifies that uniform distribution is used in distributing the particles 

into the source matrix. 

'Exponential depth distribution' button  

 

Specifies that exponential distribution is used in distributing the 

particles into the source matrix. The parameters of the exponential 

depth distribution can then be edited in the particle properties.  
Only available with spherical particles, or spherical surface layer. 

Disables matrix side thickness, a cylindrical source is assumed with this option. 

 

 Particle properties for specifying the exponential depth distribution are included. The 

rest of the particle properties are same as in the radioactive particles source case:  

Percentage to distribute exponentially  

 

The percentage of the particles to be distributed 

exponentially into the source matrix. The rest 

are on the surface of the matrix.  
Only available with exponential depth distribution 

Mean penetration depth  

 

The mean penetration depth of the particles in 

the source matrix.   
Only available with exponential depth distribution 

 

The source matrix housing the particles is defined in the same way as in the option of 

homogeneous source, except that: 

 

 Only central thickness is used if exponential depth distribution is selected. The source 

matrix is considered to be cylindrical 
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3.4. The absorbing layers page 

 

The absorbing layers page allows you to add layers of different materials between the radiation 

source and the detector. This page contains only one window. 

3.4.1. Using absorbing layers 

To enable or disable the use of absorbing layers use the following controls: 

The 'No absorbing layers' button 

 

Disables the use of absorbing layers. This button provides a 

convenient way to remove the effects of the absorbing material 

layers in a simulation. 

The 'Use absorbing layers' button 

 

Enables the use of absorbing layers. The layers can now be added, 

removed and edited via futher controls. 

 

To add, remove and edit the absorbing layers use the following controls: 

The layers table 

 

Use this table to select the absorbing layer to 

edit by left clicking the corresponding row. 

When a layer is selected its properties are 

then shown in the layer density,  thickness 

and thickness fluctuation fields. The layer 

material is displayed in the layer element 

composition table and the layer can be 

removed with the delete layer button. 
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The 'add layer' button 

 

This button adds an absorbing layer to the layers table. The layer will 

initially have thickness of 1 µm, density of 1 g/cm
3
 and elemental 

composition of hydrogen. The layer can now be selected in the layers table 

and its properties edited. 

The 'delete layer' button 

 

This button deletes the layer currently selected in the layers table. The 

selected layer is denoted by highlighted background. The deleted layer is 

then lost and won't be considered in the simulation. 

The layer density field 

 

This field lets you specify the density of the currently 

selected layer. 

The layer thickness field 

 

This field lets you specify the thickness of  the currently 

selected layer.            

The layer thickness fluctuations field 

 

The standard deviation of the normally distributed 

thickness fluctuations of the currently selected layer.  

'Layer element composition' table 

 

This table displays the elemental composition of the currently 

selected layer. By clicking on the white area of table you will be 

able to edit the material. See section 3.7 editing materials with the 

material editor. 
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3.5. The coincidences & backscattering page 

 
 

Two phenomena that may influence the alpha particle energy spectra are coincidences and 

backscattering. The former is caused by the coincident detection of the alpha particle and the 

particles (electrons, x-rays) emitted by daughter nucleus. The latter is caused by the alpha 

particles rebounding from the backing plate due to elastic scattering, 

3.5.1. Enabling coincidences and backscattering 

Important! To enable coincidence or backscattering calculations, your nuclide library must 

contain additional data about the nuclides. For this purpose a library called 

PuCoincidences.xml is supplied with your AASI. Please note that the default library 

NuclideLibrary.xml does not contain the coincidence information! Use the coincidence data 

browser to verify that the nuclides you have selected into the simulation have this additional 

library data. Nuclides with coincidence data will be displayed with blue color in the 'nuclides 

selected for simulation' table in the source page. 

 

Note that the coincidence data format has changed, and the libraries from previous versions of 

AASI are now incompatible with version 2.0. 

 

 To include coincidence effects in your simulations use the following controls: 

 

The 'Store coincidence output in a file’ checkbox 

The 'Calculate coincidences' checkbox 

 

This checkbox enables or disables the calculation 

the coincidences between an alpha particle and 

electrons and x-rays. 
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The 'Include backingplate in calculations' checkbox 

 

This checkbox enables or disables 

the use of backingplate in 

calculations. 

The 'Track alpha particles' checkbox 

 
 

 

Track alpha particles in the source 

backing plate.  

Important: thin source is assumed! 

Energy loss in the source matrix is 

assumed to be negligible! 

 
This feature is only available with ‘Include 

backing plate’ option. 

The 'Coincidence output selector' button 

 

Use this button to open up a file 

browser to choose the coincidence 

output file. 

The 'Coincidence output file' field 

 

Give the path to the coincidence 

output file using this field. 

The backingplate material list 

 

The material of the backingplate 

has an impact on the backscattering 

effect. Use this list to choose the 

element the backingplate is 

composed of.  

The backingplate density 

 

Use this field to specify the density of the backingplate 

material. Values in this field are required to be in the 

range (0, 23)  

The backingplate thickness 

 

This checkbox enables or disables the storing of the 

simulated coincidence data into a file. Use the 

coincidence output file field and coincidence output 

file selector to specify the filename. 
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Use this field to specify the thickness of the backingplate 

in micrometers. The values are required to be > 0. 

The backingplate atomic number 

 

This field displays the backingplate materials atomic 

number. 

The backingplate mass number 

 

Use this field to specify an isotope of the backingplate 

material. 

The shielding model list 

 

Allows you to choose the shielding model for screened 

Rutherford scattering of electrons.  

The 'parallel beam emission' checkbox 

 

Electrons are emitted parallel to the 

detectors symmetry axis, i.e. electrons 

impinge the the detector at 90 degree 

angle. This option is useful for 

backscattering studies. 

The 'Linear deposition model in the dead layer' checkbox 

 

Electrons deposit part of their energy in 

the detected signal. Deposited energy in 

the forming of the pulse increases linearly 

with the depth. 
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3.5.2. Viewing coincidence data on nuclides 

Use the coincidence data browser to view coincidence data for nuclides in a library or in the 

current simulation. You may open a library and select the nuclide whose data you want to 

view by using the following controls: 

 

The 'Browse data for library' button 

 

This button enables you to browse 

coincidence data for nuclides in a library. 

The nuclide library can be opened using the 

open library button below. Choose the 

nuclide whose data you want to view using 

the list right next to the open library 

button.The coincidence data for the selected 

nuclide will then be displayed in the bottom 

of the coincidence info browser. If the 

library you have opened has no nuclides 

with coincidence data, then the list will 

simply display 'no coincidence data' item. 

 

You can view the data for nuclides currently selected for the simulation by using the following 

controls: 

 

The 'Browse data for simulation' button 

 

This button enables you to browse 

coincidence data for nuclides currently 

selected for simulation. The table below 

displays all the nuclides in the current 

simulation with coincidence data. You may 

choose the nuclide whose data you want to 

view by selecting it in the table. The 

coincidence data for the selected nuclide 

will then be displayed in the bottom of the 

coincidence info browser. If the simulation 

currently has no nuclides with coincidence 

data, the table will be empty.   
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3.6. The simulation page 

 

This page is used to run the geometric efficiency and spectrum simulation calculations. The 

windows on this page can also be used to set some properties of the calculations. This page 

contains two windows, one for geometric efficiency calculation, and another for the spectrum 

simulation. 

3.6.1. Simulation options and running 

There are a variety of ways to launch the simulation calculation when a desired set of 

properties has been entered in the detector page and the source page. Using the calculation 

page provides the method with the most control over the simulation, such as a specific binning 

size and control over plotting and information to display about the simulation.  

3.6.1.1. Running the simulation using the simulation window 

 

The simulation window allows you to set the binning size for energies of the spectra, apply 

Gaussian straggling and control the info window popup and multiple nuclide plotting behavior 

using the following controls: 

The energy bin size 

 
Sets the output energy bin size for the 

simulation. 

The 'include gaussian straggling' checkbox  

 
Uses Gaussian straggling in the energy loss 

calculations. 

The 'Emissions in the source detector cone only' checkbox  

 
 

Alpha particles will be emitted towards the 

detector only instead of all directions. This 

will reduce simulation time. 

The integration step field 
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In this field you may specify the length of the 

step used when calculating alpha particle 

energy loss.  

 

The 'plot sum graph only' checkbox  

 
Controls the behaviour of plotting when 

multiple nuclides are selected for simulation. 

When this option is selected only the sum of 

the nuclides energies is plotted. When 

deselected the independent spectra of the 

nuclides will be plotted in addition to the sum. 

The 'popup info window' checkbox  

 
When selected the simulation info browser is 

popped up. When deselected no info window 

is shown.  

3.6.1.2. Running the simulation using the run menu 

 

The run menu allows you to run the simulation quickly, without turning to the calculation 

page. All the options selected in the Simulation window are in use when you use the run 

menu. To launch the simulation use the Run->Run simulation menu item or the ctrl+r 

keyboard shortcut. 

3.6.2. Geometric efficiency calculation 

The geometric efficiency calculation window allows for calculating the geometric detection 

efficiency for a certain measurement setup. Like the simulation, the geometric efficiency 

calculation can be started in variety of ways. 

3.6.2.1. Using the geometric efficiency calculation window 

In the geometric efficiency calculation window the measurement setup can be specified using 

the following controls: 

The source detector distance  

 
The distance of the source surface from the 

detector. Note that the source and the 

detector geometries are coplanar and this is 

the distance between the planes that contain 

them.  

The detector diameter  

 
The diameter of the detector window for 

geometric efficiency calculation. The 

detector window geometry is a disc with 

this diameter, coplanar with the xy-plane. 

 



 28 

 

 

 

  

The desired standard deviation  

 
The desired relative standard deviation to 

achieve by the calculation. Smaller values 

will yield more accurate results at the cost 

of longer running time.At short source-

detector distances smaller values may be 

used, but at long distances larger values 

may be needed. 

The 'source diameter' button  

 
Specify the diameter of the source disc.  

 

The 'area’ field  

 
 

Specify the area of the source disc.  

  

The 'offset' field  

 
 

Specify the offset (lateral distance between 

the detector and source disc centers). 

The 'point source' button  

 
With this option the source is a point in the 

xy plane. Note that the source-detector 

distance is the distance between the planes 

that contain the source and the detector. 

  

3.6.2.2. Calculating geometric efficiency using the run menu 

 

Using the run menu is a quick way to run the geometric efficiency calculation without turning 

to the calculation page. Selecting the run geometric efficiency calculation item or by invoking 

its keyboard shortcut ctrl+g in the run menu will cause the geometric efficiency calculation 

window to pop up. This can then be used exactly like the one in the calculation page.  
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3.7. The plot page 

 

The plot page displays the spectrum simulation results. The plot page contains a single window 

that allows you to load previous results or measurements and display them together with your 

current session simulations. Saving the figures in different formats and printing are also 

supported. 

3.7.1. Displaying alpha spectra in the plot page 

The plot page is automatically brought to the front by the program when a simulation is 

completed. This enables the user to quickly see the results, which are displayed as graphs of 

counts against energy. The plot page also contains tools for zooming and translating the graph 

display, as well as creating figures by editing axis titles, adding annotations and so on. 

3.7.1.1. The graph display properties 

 

Some basic properties of the graph display can be set using the display properties pane on the 

right of the view. Use the following controls: 

The 'Energy plot range' &  'Counts plot range' buttons 

 

These buttons let you specify the range on the desired axis 

to be displayed in the graph display. These buttons enable 

the range fields to their right that can be used to specify 

the minimum and maximum value to be displayed. Press 

enter to apply the new range after typing in the desired 

value. 

 
Hint: pressing this button when it is selected will redraw the graph 

display with the values of the range fields, this can useful when using 

the zoom or pan tools. 
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The 'Energy auto' &  'Counts auto' buttons 

 

These buttons select automatical determination of plot 

range. When these buttons are selected and a new graph is 

introduced into the graph display, the display range will be 

set to be the minimum and maximum of the graphs in the 

graph display. Effectively ensuring that all data contained 

in the graphs is shown. 

  
Hint: pressing this button when it is selected will determine the range 

and redraw the graph display, this can useful when using the zoom or 

pan tools. 

The graph selection list 

 

This list is used to select a graph to be set as currently 

selected. Once a graph is selected, its properties can then 

be edited in the Spectrum properties compartment. It is 

noteworthy that the graph displayed at this list is also used 

in some other places, most notably when saving graphs. 

See section 3.6.2 Loading, saving and printing alpha 

spectra for details.  

 

Alternatively, you may use the selection tool to select a 

graph. The selected graph is displayed in transparent red 

when the selection tool is activated. 

 

The x- and y-axis specific properties can be edited in the x-axis and y-axis compartments. The 

compartments can be expanded by pressing the „+‟ symbol. 

 and  

 They will reveal the following controls: 

The 'X-Axis title' & ‘Y-Axis title’ fields 

 

In this field you can set the title for the x- or y-axis. The font of 

the title can be changed using the button to the right of this 

field. Note that you need to press enter after you have typed the 

new title for the changes to be reflected in the graph display. 

Press enter to apply the new title. 

The 'Linear X-Axis' &  'Linear Y-Axis' buttons 

 

This button selects linear scale to be used in the graph display 

for the x- or y-axis.  

The 'Logarithmic X-Axis' and  'Logarithmic Y-Axis' buttons 

 

This button selects logarithmic scale to be used in the graph 

display for the x- or y-axis.  
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The currently selected spectrum properties can be edited by expanding the Spectrum 

properties compartment. 

 

 It will reveal the following controls: 

The graph title field 

 

This field is used to give edit the name of the graph. The name 

is used only as the display name in the graph selection list, but 

the user may change the name. Press enter to apply the new 

name. 

The graph color field 

 

This field is used to edit the color of the graph in the graph 

display. Clicking on this field will popup a color selector from 

which the desired color can be picked. This and the following 

option are useful when comparing graphs from different 

simulations. 

The graph width 

 

This field is used to edit the width of the graph in the graph 

display. Note that widths smaller than 1 are allowed. Press enter 

to apply the new stroke width. 

The fill graph checkbox 

 

Checking this box will make the space between the graph and the 

X-Axis (energy) appear filled by the graph color. This option can 

be useful when comparing many graphs to a specific graph. 

The ’To front’ and ’To back’ buttons 

 

These buttons affect the order in which the graphs are rendered 

onto the graph display. To front moves the current graph in front of 

all other graphs while To back button does the converse. 

The Energy shift field 

 

This field is only available for graphs loaded from a 

.phd file. The graph may be shifted by the amount 

specified in the field. Pressing enter will apply the 

energy shift. 
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3.7.1.2. Navigating the graph display 

 

Sometimes it is desirable to view an area of interest in the graph without displaying the whole 

range of the energy spectrum. In such case, you may use the following controls: 

The 'zoom tool' toggle button 

 
This button toggles the zoom tool on. Left-clicking on the graph 

display will then increase zoom in the view, displaying more detail 

near the clicked point. Right-clicking decreases zoom, displaying less 

detail but larger range. Dragging the mouse zooms to a specific 

region, specified by the drag rectangle. Dragging the mouse outside 

the axis will constrain the zoom to the nearest axis. 

The 'pan tool' toggle button 

 
This button toggles the pan tool on. Dragging on the graph display 

will move the display to the direction of the drag. Dragging the 

mouse outside the axis will contrain movement to the nearest axis. 

The 'reset view' button 

 
This button resets the view so that the whole spectrum range will be 

visible. 

 

The graph display can also be navigated using the range fields on the display properties pane. 

3.7.1.3. Annotating a figure 

 

The figure that is shown on the graph display can be annotated by adding text and lines. There 

are two types of each object to add, plain objects and tag objects, e.g. for text there are text 

objects and text tag objects. The difference between the two is that plain objects are not 

affected by navigation such as zoom and pan, whereas the tag objects are. The plain objects 

are therefore suitable for adding a figure title or explanation of what the figure is about. The 

tag objects could be used for instance to add an explanation for a peak in the figure, in this 

case when the peak is panned out of view, the annotation would also.  

 

 To select, add or edit an annotation use the following controls: 

The 'selection' tool 

 
This button toggles the selection tool on. When this tool is 

selected, the handles of the annotations are displayed and 

you can use them to select annotations and edit them.You 

can select an annotation by left clicking its handle. Left 

clicking again on the handle of the selected annotation starts 

editing of the selected annotation. 
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The Annotations→Add text  menu item 

 

This item toggles the text annotation tool on. When this 

item is selected, left-clicking on the graph display will add a 

text annotation to the position of the click. You may then 

type in the text and use the button to the left of the textfield 

to change the font. To edit a previous text annotation use 

the select tool, select the lower left corner of the text 

annotation and left-click twice. 

The  Annotations→Add line menu item 

 

This item toggles the line annotation tool on. When this tool 

is selected, dragging the mouse in the graph display will 

result in a line annotation being added between the starting 

and ending point of the drag. To edit a previous line 

annotation use the select tool, select the beginning or ending 

point of the line and drag it to a new location. 

The Annotations→Add text tag menu item 

 

This button item the text tag tool on. When this tool is 

selected, left-clicking on the graph display will add a text 

tag to the position of the click. Note that you must add the 

tag into the visible space between the axii.. 

The Annotations→Add line tag menu item 

 

This item toggles the line tag tool on. When this tool is 

selected, dragging the mouse in the graph display will result 

in a line annotation being added between the starting and 

ending point of the drag. Note that you must add the line tag 

into the visible space between the axii. 

The Annotations→Remove selected annotation  menu item 

 

When selected, this item erases the currently selected 

annotation. 
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3.7.2. Loading, saving and printing alpha spectra 

The plot page can also be used to load and save alpha spectra in various different formats. 

When saving spectra it should be noted that when the graph display is displaying several 

spectra, the one that will be saved is the currently selected spectrum. Use the following 

controls: 

 

The File→Open… menu item 

 

Adds a graph from a file into the graph display. Note 

that when loading .fig files, all graphs already in the 

graph display will be removed prior to loading. 

Loading a bitmap format will add it as an image 

annotation. 

The File→Save currently selected graph to disk menu item 

 

Saves the currently selected spectrum to file. Pressing 

the button pops up a filechooser dialog that lets you 

select the desired output filename and format. Only 

.phd, .graph and .fig files can then be subsequently 

read back to AASI.  

The File→Print… menu item 

 

Prints the figure in the graph display. A print dialog is 

shown, allowing you to select the printer and paper 

options. 

The File→Page setup & preview… menu item 

 

Allows you to setup the page for printing. A dialog is 

shown that displays you a preview of the print and 

tools that allow you to reposition or enlarge the figure 

as it will appear on the printed page. Clicking ok will 

apply the settings, and they will be in effect from that 

point on. Cancel will discard the changes into the page 

setup. 

The File→Save plot as figure… menu item 

 

Saves the current plot as a figure, complete with all 

the graphs, annotations, axii and tics. The figure 

format may be chosen to be either a bitmap, scalable 

vector graphics or AASI figure. Only AASI figure 

(.fig) is editable with AASI after saving. 
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3.7.2.1. File formats for figures and graphs 

AASI can open files in .phd, .graph and .fig formats, and save graphs in .phd, .graph, .fig, 

.eps, .ps, and .phd formats. Out of these formats .phd and .graph are best suited for further 

processing or analysis of data, and the rest are more suited for presentations and the like. 

Here is a summary of the file formats: 

 
Format Filename 

extension 

can read can write description 

Graph .graph yes yes 

The AASI graph format. ASCII, one graph. 

Format:  

x, c, y per row. Interpretation: x is the left edge of 

bin in MeV, c is the center of the bin in MeV, y is 

number of counts in that bin. 

Figure .fig yes yes 
The AASI figure format. Binary, multiple graphs 

with annotations. 

IMS2.0 .phd yes yes 

IAEA message format, ASCII, an energy 

calibration under #gEnergy tag, consisting of 

channel - energy pairs. The reference point for the 

channel is the centroid.  Channel contents are 

found under #gChannels tag. The channels are 

enumerated from 1…n in groups of 5 

IEC .iec yes no 

Canberra exchange format, ASCII, much like the 

IMS2.0, except does not have human-readable tag 

names. 

Adobe pdf .pdf no yes 
Portable document format, binary, scalable vector 

graphics. 

PostScript .ps no yes 
Printer command language format, scalable vector 

graphics. 

Encapsulated 

PostScript 
.eps no yes 

Printer command language format, scalable vector 

graphics. 

Portable 

network 

graphics 

.png yes yes 

Bitmap format. 

Compuserve 

graphics 

interchange 

.gif no yes 

Bitmap format. 
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3.8. Editing materials with the material editor 

 

The material editor is used to edit the materials of various components in the simulation 

setup. A material in AASI is an element, a compound or a mixture. The material editor allows 

you to edit these types of materials, or to choose a material from a list of presets.  

 

To choose a material from the presets use the following controls: 

 

The presets list 

 
Selects the material from a list of presets.  

 

To choose between the type of material to edit, use the following controls: 

'Compound material' button 

 Selects the material type to be compound. This is also the 

recommended material type for single element materials.  

'Mixture material' button 

 Selects the type of material to be mixture.  

 

To inspect the properties of the current material you may plot its stopping power: 

Plot stopping power button 

 
This button plots the stopping power of the 

material currently in the material editor. A 

plot window is popped up that displays the 

graph of the stopping power. The plot can be 

navigated in the same way as the plot page. 
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3.8.1. Editing compound materials   

When a compound material type has been selected, the chemical composition of the 

compound can then be specified by giving its molecular or empirical formula using the 

following control: 

'Molecular formula' field 

 

Use this field to give the empirical or molecular 

formula of the compound. Use chemical symbols to 

specify the constituent elements and subscripted 

number to denote the number of atoms of that element. 

Use superscripted number in front of element symbol to 

denote an isotope.  You can change a number from 

subscript to superscript by up and down arrows. The 

elements in the compound are enumerated to the right 

of the field. 

 

You may also give the formula using the periodic table window and clicking the desired 

elements. See 3.7.4 using the periodic table window. 

3.8.2. Editing mixture materials 

When a mixture material type has been selected further controls for mixture editing will be 

enabled. The mixture is specified by selecting the elements in the mixture 

Element list 

 

Use this list to select an element for the mixture. The 

element can then be moved to the mixture elements 

table using the add element to mixture button. When an 

element is selected in the list, information about it will 

be displayed below.  

 

The element list also includes two molecules: UO2 and 

ThO2 with specific stopping power parameterisations 

available from literature.  

Add element to mixture button 

 

Use this button to add an element into the mixture elements table. The element 

in the mixture can then be edited. 

Remove element from mixture button 

 

Use this button to remove an element from the mixture elements table.  
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Mixture elements table 

 

Use this table to define the mixture 

when the constituent elements have 

been selected.      Use the mass 

percentage column by either 

dragging the histograms or clicking 

mouse button and entering a value 

to specify the relative mass 

percentage of the element in the 

mixture. 

 The A column may be used to 

specify an isotope element.  

 

You may also give the elements in the mixture by using the periodic table window and 

clicking the desired elements.  

3.8.3. Using material presets 

Material presets allow loading and saving of materials defined using the material editor. You 

can save common or often needed materials as presets when the desired compound or mixture 

has been defined.  

 

To save the material currently in the material editor as a preset use the following controls: 

Save preset button 

 
Clicking this button allows you to save the 

material currently under editing as a preset. You 

will be prompted for the name and density of the 

material. After you have saved the material it 

will become available in the preset list for quick 

recall. 

 

To remove the currently selected preset from the list of preset materials use the following 

controls: 

Save preset button 

 
Clicking this button will remove the preset 

material currently displayed in the preset list 

view. 

3.8.4. Using the periodic table window 

The periodic table window can be used to specify the elements used in the material.  

 

For compound materials: 

- Click the desired element with mouse. The element you clicked will be added to the 

compound formula field. Subsequent clicks on the same element will increment the number of 

atoms for that element e.g. clicking O twice would add O2 into the compound formula field. 
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For mixture materials: 

- Click the desired element with mouse. The element you clicked will be added into the 

mixture elements table as a new row. 

3.9. The simulation info browser 

The simulation info browser can be used to view additional information about the last 

simulation run. It may optionally be automatically opened after simulation in the same fashion 

as the plot page, or it may be opened using the view->Simulation info browser menu item. To 

view the information, use the following controls: 

 

The nuclide info list 

 

Selects the nuclide for which additional simulation 

information is displayed. The list contains all the 

nuclides that were used in the last simulation run. 

When you select a nuclide in the list,  the pages below 

will be filled with the information pertaining to that 

nuclide.  

 

The simulation info pages 

 

Chooses the information to view on the simulation of 

the nuclide selected in the nuclide info list. The 

'general' information will always be available, the 

availability of the rest of the information depends on 

the simulation options used in the last run.  
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4. TASKS & EXAMPLES 

In this section you will find some tasks and examples that walk you through certain type of 

simulations. You may use the Welcome page to open the examples by clicking the button next to 

the example description. Doing so will cause the plot page to be opened with an informative 

figure. By going through these examples, you will familiarise yourself with the use of AASI 

program for alpha spectrometric simulations. 

4.1. Example 1 

The first example file is a simulation of an alpha spectrum from the so-called “thule particle” 

(it is in fact this particle that is depicted in the SEM images in the cover of this book and on 

the welcome page of AASI). The properties of the “thule particle” are well known, and in this 

example we will compare the simulated spectrum to the measured one. Try the following 

steps: 

 

1. Turn to the welcome page. 

 
  Click the ‘Welcome’ tab. 

   
 

If the tab is not visible, use Help → Show welcome page menu item.  

 
Select from the top menubar, help menu. 

 
 

Open the first example by clicking the „open‟ button next to Example 1 on the 

welcome page. 

 
Click the ‘open’ button. 

 
 

The plot page opens and displays information about this example and an actual alpha 

spectrum measured from the “thule particle”.  
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2. Open the graph properties pane and set the color of the graph to light blue. 

 
Click the green ‘+’                             Click the grey area. 

  
 

3. Turn to the simulation page. 

 
Click the ‘Simulation’ tab. 

 
 

 Make sure the „plot sum graph only‟ option is checked in the spectrum simulation 

window. 

 
Click the checkbox so that a checkmark appears. 

 
 

4. Press the „Run simulation‟ button to begin the simulation.  
 

Click the button. 

 
 

When the simulation is done AASI will turn to the plot page automatically. The 

resulting spectrum is displayed as a black graph on top of the measured light blue 

spectrum.  
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The result of the simulation. The measured spectrum displayed in light blue, the simulated spectrum is displayed as black. 

 
 

 

5. Select the „zoom‟ tool. 

 
Click the icon to activate the zoom tool 

 
 

Zoom in by dragging the mouse near the text. The zoom rectangle denotes the new 

view bounds. 

 
Click  on the display area to define the upper left corner of the zoom rectangle. Keep the button down and drag to define the extents. 

 
 

 Note that zooming is constrained when you start the drag outside the axis. Try using 

the „pan‟ tool: drag the mouse on the graph display area to drag the view bounds to 

new location. Use the „pan‟ and the „zoom‟ tool to take a look at the different parts 

of the spectra closer up. If you get lost, you may return the original view bounds by 

pressing the „reset view‟ button.  
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4.2. Example 2 

This example simulates a typical alpha spectrum from a fluoropore air-filter. In this example we 

will take a look at how the various properties of the source matrix affect the resulting spectrum. 

We start off similar to Example 1. Try the following steps: 

 

1. Turn to the welcome page. 

 
  Click the ‘Welcome’ tab. 

   
 

If the tab is not visible, use Help → Show welcome page menu item.  

 
Select from the top menubar, help menu. 

 
 

Open the first example by clicking the „open‟ button next to Example 2 on the 

welcome page. 

 
Click the ‘open’ button. 

 
 

The plot page opens and displays information about this example and an actual alpha 

spectrum measured from a fluoropore filter.  

 

2. Turn to the simulation page. 

 
Click the ‘Simulation’ tab. 

 
 

 Make sure the „display sum graph only‟ option is not checked in the spectrum 

simulation window. 
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Click the checkbox so that the checkmark disappears. 

 
 

3. Press the „Run simulation‟ button to begin the simulation.  
 

Click the button. 

 
 

When the simulation is done AASI will turn to the plot page automatically. The 

spectral components resulting from the different radionuclides in the source will be 

displayed along with the sum spectrum. Notice that the energy calibration of the 

measured spectrum doesn‟t quite match the simulation. 

 

Set the fluoropore spectrum to be the currently selected graph using the graph 

selection list, then use the graph properties to shift it by -0.05 MeV 

 
Select ‘Fluoropore spectrum’ from the list        Click, type in new value, press enter. 

  
 

 

4. Turn to the source page 

 
Click the ‘Source’ tab. 

 
 

5. Make the filter thicker by changing the thickness of the source matrix in the source 

window, write in value of  300 µm 
 
Click the field with the value 150.0 and type in new value 300 and press enter. 
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Run the simulation again (do steps 2 & 3), notice that the thickness of the source 

matrix did not have a big impact on the resulting spectrum. The reason for this is that 

the particles are distributed close to the surface, with mean penetration depth only 15 

µm. 

 

6. Turn to the source page again (step 4), change the mean penetration depth of the 

particles to 50 µm. 

 
Click the field with the value 15.0 and type in new value 50 and press enter. 

 
 

Run the simulation again (do steps 2 & 3). There are still no large changes. The 

reason is that only 5 % of the particles are distributed into the source matrix, the rest 

are on the surface.  

 

7. Go back to the source page and change the percentage to distribute exponentially to 

50 % 
 
Click the field with the value 5.0 and type in new value 50 and press enter. 

 
 

Run the simulation again, this time the peaks exhibit much wider tails.  

 

8. Turn back to the source page, try to change the way the particles are distributed into 

the source matrix, use uniform distribution instead of exponential. Also try different 

parameter values. 
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4.3. Example 3 

This example simulates a typical alpha spectrum from a CAMFIL air-filter. In this example we 

will take a look at how the various properties of the radioactive particles embedded in the source 

matrix affect the resulting spectrum. We start off similar to Examples 1 & 2. Try the following 

steps: 

 

1. Turn to the welcome page. 

 
  Click the ‘Welcome’ tab. 

   
 

If the tab is not visible, use Help → Show welcome page menu item.  

 
Select from the top menubar, help menu. 

 
 

Open the first example by clicking the „open‟ button next to Example 3 on the 

welcome page. 

 
Click the ‘open’ button. 

 
 

The plot page opens and displays information about this example and an actual alpha 

spectrum measured from a fluoropore filter.  

 

2. Turn to the simulation page. 

 
Click the ‘Simulation’ tab. 

 
 

 Make sure the „display sum graph only‟ option is not checked in the spectrum 

simulation window. 
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Click the checkbox so that the checkmark disappears. 

 
 

At this point, open the sketch window by selecting View→Sketch window menu 

item. 

 
Select from the top menubar.  

 
 

3. Press the „Run simulation‟ button to begin the simulation.  
 

Click the button. 

 
 

When the simulation is done AASI will turn to the plot page automatically. The 

spectral components resulting from the different radionuclides in the source will be 

displayed along with the sum spectrum.  

 

4. Turn back to the source page, and edit the particle size distribution, you will see a 

visual representation of the distribution in the sketch window. Use the following 

values, mean diameter = 2.0, Geometric standard deviation = 1.1, Diameter ceiling = 

3.  

  
Click the property, type in new value, press enter.         The sketch window shows the particle size concentrated around 2. 

  
 

5. Run the simulation again. Notice that the peaks have now a much rounder shape, due 

to the larger mean size of the particles. Delete all graphs and annotations by using 

the Graphs→Remove all graphs and Annotations→Remove all annotations menu 

items in the simulation plot window. 
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6. Turn back to the source page. Change the particle type to ellipsoidal, and edit the 

following particle properties: X diameter = 7, Y diameter = 12, Z diameter = 5 

 
Click the button.            Click the property, type in new value and press enter. 

  
 

7. Run the simulation. Notice that the tailing is very extreme. This is due to the fact that 

the exponential distribution, and hence the mean penetration depth, are not used with 

ellipsoidal particles. Ellipsoidal particles are always distributed into the source 

matrix with uniform distribution. 
 

8.  Remove all the graphs. Go to the source page and edit the thickness of the source 

matrix. Give the value of 10 µm. 

 
Click the property, type in new value and press enter. 

 
 

Run the simulation again. 
 

9. Now the peaks exhibit a round shape. To get sharper peaks, go to the source page 

and decrease Z diameter in particle properties (say, to 1 µm). This will work because 

the Z axis is the axis pointing towards the detector. 
 

10. Experiment with the effects of different properties. 
 

4.4. Task 1 - Basic operation 

It is a good idea to go through the example files included in the AASI distribution, see previous 

sections for details. After you are done with them, you might try the following: 

 

 Open the file Example1.inp.  

 Make modifications to the detector on the „detector page‟. And save the detector using the 

save detector button. Don‟t overwrite the existing detector file. 

 Open Example2.inp by using the button in the welcome page. Notice that the detector resets 

to the one saved with this particular example file.  

 Again modify the detector, save it and this time overwrite the detector file.  

 Open any of the example files, notice that the values for the detector in all of them are now 

the ones you specified in the previous steps. 

 Change the source material, and save it as a new preset material.  

 Assign the material you saved in the previous step to the particles by editing the particle 

material and using the material presets list. 
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4.5. Task 2 - Creating a new example file 

First edit the simulation properties found on the different pages until a desired set of properties 

is obtained. Edit the notes in the notes window. Now save the file as Example 5.inp under the 

directory Aasi/examples/. Now open the text file examples.prs in the same directory. Add the 

following entry  

 example_5_desc = My own example file! 

Now when you start AASI again, you will see the fifth example you just added in the welcome 

page. This feature can be used to add often needed combinations of parameters into the 

welcome page for quick recall. 

 

4.6. Task 3 - Running a simulation from the command line 

Open a command line interface (in windows start->run, type cmd and hit enter). Go to your 

Aasi/bin directory and invoke Aasi by writing alpha4_1.exe < Input.inp. This will cause Aasi to 

run simulation with parameter values defined in Input.inp file. The outputs from the simulations 

will be written to files results.dat and result.phd. 

4.7. Task 4 - Creating a figure 

Open the file Example 3.inp and run the simulation by pressing ctr+r. The plot page will 

automatically be displayed. Now zoom closer to the peak show in the plot by clicking the 

zoom button and dragging the mouse below the Energy axis from around x MeV to y MeV. 

Now add a line tag into the plot by clicking the add line tag button and dragging the mouse 

from the tip of the peak onto the white space to its left. Now add a text tag into the plot by 

clicking the add text tag button and clicking on the white space besides the left end point of 

the line. Write peak into the text addition box. Now you should be in the following situation. 

Now add a title by clicking add text button and adding the text to the white space above the 

figure. Write Simulation of xxx. Change the font by clicking the change font button. Select 

size 28 pt and style Bold. End text adding by clicking the mouse outside the text addition box. 

Now save your figure by clicking save. Select type as .fig and type in the name figure.fig and 

press ok. Now try zooming the plot to see how the tag objects behave under the changes of 

view. 
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5. AASI DIRECTORY STRUCTURE AND FILES 

We will now describe the files installed, required and used by the AASI application.  

5.1.  What gets installed 

When you install AASI a multitude of files, most essential to correct operation of the 

software, will be placed on your hard-drive. First and foremost, a directory (on some systems 

called a folder) named AASI will be created. Everything needed to operate the software will 

be placed under that directory, often referred to as AASI directory. We will now describe each 

file that should be present after the installation. All the files are required to be present to 

successfully starting AASI, unless explicitly stated to be optional: 

 
AASI - A directory, contains everything necessary to operate the AASI software 

∟ Aasi.exe - Windows only, the AASI application launcher. Optional if you know how to execute java jar files.  

 Aasi.sh - Linux / Unix only,  AASI application launch script. Optional if you know how to execute  java jar files. 

 UsersManual.pdf - This file. Optional. 

 detectors 
- A directory. This directory is part of the detector search path, so place often used detectors here. 

Optional. 

 examples - A directory. Contains the example files. Optional. 

 ∟ examples.prs - The example settings. Optional. 

  Example 1.inp - The first example input file. Optional. 

  Example 2.inp - The second example input file. Optional. 

  Example 3.inp - The third example input file. Optional. 

  Example 4.inp - The fourth example input file. Optional. 

 bin - A directory. Contains mostly the binaries, and the data needed by them. 

 ∟ alpha4_1.exe - The simulator back-end executable binary. 

  AASI_Frontend.jar - The front end application executable java jar file. 

  LibraryManager.jar 
- The nuclide library management program. Executable java jar file. 

(Experimental, optional) 
  NuclideLibrary.xml - Library data on radionuclides, based on the ENSDF databases.  

  PuCoincidences.xml - Library data on radionuclides with specific additions of coincidence data. 

  stopping.dat - Stopping power coefficient data. 

  photoelAttData.dat - photoelectric attenuation data. 

  Input.inp 
- The default input, loaded at startup of the application. This is requred to be 

present and acceptable! 
  ErrorCodes.txt -A summary of runtime error codes from the simulator back-end. 

  
Detector.det 

- The default detector, loaded at startup of the application. This is requred to be 

present and acceptable! This is also the detector which is used if the detector 

specified in an input file cannot be found. 
  

lib - a directory containing mostly libraries and data required by the binaries. 

  ∟ wins.prs 
- Window settings between sessions. 

Optional.  

   plot.prs 
- Plot settings between sessions. 

Optional. 

   mixtures.prs - Material presets. Optional. 
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   ParameterSets.xml 
- Parameter descriptions for the 

front end. 

   InputTemplate.dat 
- Input file file-format description 

for i/o.  

   DetectorTemplate.dat 
- Detector file-format description for 

i/o. 

   GeometricEfficiencyTemplate.dat - Geom. eff. file-format description. 

   Elements.dat - data on elements 

   Widgets.jar - Java library 

   Objectify.jar - Java library 

   epsgraphics.jar - Java library 

   JFontChooser.jar - Java library 

   AbsoluteLayout.jar - Java library 

   jh.jar - Java library 

   freehep-graphicsio-svg.jar - Java library 

   freehep-graphicsio-pdf.jar - Java library 

   freehep-graphicsio-ps.jar - Java library 

   freehep-graphicsio-gif.jar - Java library 

   freehep-graphicsio-emf.jar - Java library 

   freehep-graphicsio.jar - Java library 

   freehep-graphics2d.jar - Java library 

   freehep-base.jar - Java library 

   crimson.jar - Java library 

 jre 
- A directory. Contains the java runtime environment. Optional if you already have working java installed. 

Otherwise required. In that case this directory contains multiple subdirectories, all of which are required! 

     

 

On Microsoft Windows systems in addition to these files, a desktop shortcut, a start menu 

entry and an uninstaller are part of the installation, they are all optional. 

5.2.  The simulator and the front-end files 

To avoid confusion we have so far mostly talked about AASI application. By this we mean the 

front-end with the graphical user interface and the simulator back-end together. The simulator 

back-end however is oblivious to the existence of the front-end and may be used completely 

independently. The simulator and the libraries it requires can be found in the directory 

structure: 

 

AASI - The AASI directory 

 bin - The binary directory. 

 ∟ alpha4_1.exe 
- The simulator back-end executable binary. Can be executed 

with an input by issuing command alpha4_1.exe < Input.inp 
  NuclideLibrary.xml - Nuclide library 

  CoincidenceLibrary.xml - Nuclide library with coincidence data 

  stopping.dat - Stopping power coefficient data. 

  photoelAttData.dat - photoelectric attenuation data 

 

Rest of the files described in the previous section are used by the front-end.  
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5.3.  File formats 

As stated before, the simulator can be run without the graphical user interface. For some users 

this may be preferable, the formats of acceptable inputs are described in the following 

sections. An input consists of an „input file‟ which contains the simulation parameters, and a 

„detector file‟ which contains the detector parameters. The detector file is referenced by the 

input file, so both files must be present. A detector or input file that conforms to the 

corresponding file format is called acceptable. 

5.3.1. The input file format 

We have mentioned input files before, but only in the context of loading and saving them 

using the graphical user interface. The input files are, however, nothing but simple text files 

with the following structure: 

 
Line Description Values Example 

1 A letter specifying whether the calculation should be for 

geometric efficiency only or a full simulation. The 

following lines only apply for full simulation, geometric 

efficiency is treated in section 5.3.3. 

y = geometric efficiency only 

n = full simulation 

n 

2 Proceed to spectrum simulation. y = proceed 

n = stop 

y 

3 A float specifying the source-detector distance (SDD) in 

millimeters 
> 0 10.0 

4 A string specifying the name of the nuclide library to be 

used. 

A string enclosed in „‟ „NuclideLibrary.xml‟ 

5 The name of the nuclide to use in the simulation , or 

dummy to specify use of single line with given energy. 

The name is used to identify the source nuclide data in 

the nuclide library. 

A string enclosed in „‟ 

„dummy‟ to use single line with 

given energy 

„U-238‟ 

6 A letter specifying whether the particle shape should be 

ball or ellipsoid 

b = ball 

e = ellipsoid 

b 

7 Depending on the value of line 6 either a float specifying 

the diameter of the particles (for ball) or 3 comma 

delimited floats specifying the X,Y and Z semiaxii. 

> 0    3.0, 2.0, 1.0 

8 A letter specifying if spherical shell geometry should be 

used instead of the shape specified on line 7. 

y = use spherical shell 

n = use shape on line 7    

n 

9 An integer specifying the number of constituent 

elements in the particle material 
0,1,2,3… 1 

10 Three floats. First specifies the density of the particle 

material, the next two are unused. 
> 0 9.0, 1.0, 1.0 

Next i 

rows 

Next i rows, where i is the value on line 9, will contain 

the element description. On each row there are two 

integers and a float, element Z, element A and atomic 

fraction. 

>0, > 0, > 0 6,12, 1.0 

11 A float specifying the size of the energy bin in keV. >0 16.7 

12 An integer specifying the number of constituent 

elements in the source matrix material. 
>0 1 

13 Three floats. Density of the source material, thickness of 

the source material and thickness fluctuations in the 

source material. 

> 0 9.0, 1.0, 1.0 

Next i 

rows 

Next i rows, where i is the value on line 12, will contain 

the element description. On each row are two integers 

and a float: element Z, element A and atomic fraction. 

>0, > 0, > 0 6,12, 1.0 

14 A letter indicating whether convex source geometry 

should be used. 

y = use convex source 

n = cylindrical source 

n 
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15 Two floats specifying the thickness of the source at its 

center and at its side. These are used only if the value of 

line 14 is y 

>0, >0 10.0, 4.0 

16 A letter specifying if an exponential depth distribution 

should be used for particle deposition 

 

y = use exponential depth 

n = use uniform depth  

y 

17 Two floats, the fraction to distribute exponentially, and 

the half-depth of the distribution in micrometers. 

 

>0, >0 0.8, 14 

18 An integer specifying the number of attenuating layers >0 2 

for 

each 

layer 

An integer specifying the number of constituent 

elements in the layer material. 
>0 1 

for 

each 

layer 

Three floats. Density of the source material, thickness of 

the source material and thickness fluctuations in the 

layer material. 

> 0 9.0, 1.0, 1.0 

for 

each 

layer 

next i 

rows 

Next i rows, where i is the number of elements for this 

layer material, will contain the element description. On 

each row are two integers and a float, element Z, 

element A and atomic fraction. 

>0, > 0, > 0 6,12, 1.0 

19 a letter indicating whether many random particles should 

be created 

y = many particles randomly 

n = single particle only 

 

20 A float specifying the deposition area radius. Only used 

if value on line 19 is y 
>0 10.0 

21 A letter specifying whether a lognormal distribution 

should be used for particle sizes. Not used for single 

particle. 

y = use lognormal distribution 

n = use size specified on line 19 

y 

22 Two floats, specifying the mean diameter and geometric 

standard deviation of the lognormal size particles. Only 

used if value on line 21 is y 

>1, >0 1.0, 2.0 

23 A float specifying the maximum diameter for lognormal 

size particles 
>0 5.0 

24 Two floats specifying the x and y coordinates of particle 

location when the value on line 19 is y 
 -3.0 ,0.1 

25 An integer specifying the number of decays to simulate >0 1500000 

26 A letter specifying should only emissions into the source 

- detector cone be generated 

y = generate emissions into the 

source - detector cone only 

n = generate emissions to all 

random directions 

n 

27 A float indicating the amount of gaussian straggling to 

include 
>0  

<= 0 = don‟t include 

1.0 

28 A float indicating the size of the integration step. >0 0.2 

29 A letter indicating whether coincidences should be 

calculated 

y = include coincidences 

n = disable coincidences 

n 

30 An integer specifying should line output be printed. 1 = enable line output 

0 = disable line output 

1 

31 A letter indicating whether the source backingplate 

should be taken into account in the simulation. 

y = include backingplate 

n = forget backingplate 

n 

32 An integer specifying the number of constituent 

elements in the backingplate material 
0,1,2,3… 1 

33 Three floats. Density of the source material, thickness of 

the source material and thickness fluctuations in the 

layer material. 

> 0, >0, >0 9.0, 1.0, 1.0 
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Next i 

rows 

Next i rows, where i is the value on line 32, will contain 

the element description. On each row there are two 

integers and a float, element Z, element A and atomic 

fraction. 

>0, > 0, > 0 6,12, 1.0 

34 Two integers indicating whether to use parallel beam 

only, and whether to write particle tracking to a file 

1 = use parallel beam, or 

particle tracking 

0 = don‟t use parallel beam, or 

particle tracking 

1, 0 

35 An integer indicating whether to use linear deposition 

model for electrons in the dead layer 

1 = use linear deposition model 

0 = don‟t use linear deposition 

model 

1 

36 An integer indicating whether to print angular 

distributions 

1 = print  

0 = don‟t print 

0 

37 An integer indicating which shielding model to use 1 = Nigam 

2 = Chaoi 

3 = Moliere 

2 

38 An integer indicating whether alpha particles should be 

tracked in the backing plate. Backing plate must be 

enabled on line 31. 

1 = track 

0 = don‟t track 

0 

39 An integer indicating whether the measurement setup 

should be drawn into a .ps file 

1 = draw 

0 = don‟t draw 

0 

40 A string indicating the detector file to use. A string enclosed in ‘’ „Detector.det‟ 

41 A string indicating the coincidence output file to use.  A string enclosed in ‘’ „coincidences.ccf‟ 

42 A letter indicating whether spectrum printing to screen 

should be done 

y = print 

n = don‟t print 

n 

43 A letter indicating whether spectrum printing to a file 

should be done 

y = print 

n = don‟t print 
y 

 

For an example of an acceptable input file, see the file Input.inp in your AASI/bin directory. 

Creating a ASCII text file with the example values in the above table as rows also results in an 

acceptable input file.  
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5.3.2. The detector file format 

Like the input, the detectors are described by text files with given format: 

 
Line Description Values Example 

1 A string specifying the name of this detector a string enclosed in „‟ „450PIPS‟ 

2 A float specifying the detector radius > 0 10.0 

3 A float specifying the detector resolution (keV 

FWHM) 
> 0 14.0 

4 Three floats giving the detector responses fast, 

intermediate and slow components 
>0, >0, >0 10.0, 50.0,1000 

5 Three floats specifying total tailing, fast / 

intermediate area ratio and slow / intermediate 

area ratio 

[0 , 1]  ,>0,>0 1.0, 12.0, 0.25 

6 Two integers specifying the dead layer material Z 

and A 
>0,>0 6, 12 

7 A float specifying the thickness of the active 

volume of the detector in micron 
> 0    200.0 

 

For an example of a detector file, see the file Detector.det in your AASI/bin directory. 

Creating a ASCII text file with the example values in the above table as rows also results in an 

acceptable detector file.  

5.3.3. Input file format for geometric efficiency calculation 

The geometric efficiency calculation can be performed by using a file of the following format: 

 
Line Description Values Example 

1 A letter specifying whether this file is used for 

geometric efficiency calculation 
y y 

2 A letter specifying whether a point source shall be 

used 

y = use point source 

n = don‟t use point source 

y 

2.1 If the value on line 2 is y, then this line will contain 

two floats specifying the x and y coordinates of the 

point source. If the value on line 2 is n this line is 

omitted. 

any, any 14.0, 10.0 

3 If the value on line 2 is n, then this line will contain 

four floats specifying the detector radius, source 

offset, source radius and SDD. If the value on line 2 

is y, then this line will contain two floats specifying 

detector radius and SDD 

>0, >0,>0,>0 

or 

>0,>0 

10.0,0.0, 10.0, 10.0 

5 A float specifying the desired standard deviation for 

the calculation (in %). 
>0 0.1 

6 A letter n n 

 

Creating a ASCII text file with the example values in the above table as rows also results in an 

acceptable input file for geometric efficiency calculation.  
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5.4. Output files from the simulation 

Running a simulation produces various output files that are often left on the disc for 

convenience; they may still be of use later. The following files will be generated by the front 

end when a simulation is run: 

 
AASI  

 bin  

 
∟ Input__gen.dat 

- A generated file that is fed to the simulator as input. This file 

is left on disc after running, but will be overwritten next time a 

simulation is performed. 
  

Detector__gen.dat 
- A generated file that contains the detector used with the 

generated input. This file is left on disc after running, but will 

be overwritten next time a simulation is performed. 

  Gec__gen.dat - This file is generated for the geometric efficiency calculation. 

  dummycoincidence.ccf 
- This file is generated when no coincidence data storing is 

specified. 
 

The simulator on the other hand generates the following files as output: 

 
AASI  

 bin  

 
∟ results.dat 

- A generated file that contains the spectrum resulting from the 

simulation. The data consists of energy - counts pairs. The 

energy refers to the left edge of the energy bin. 
  

position.dat 

- A generated file that contains the positions of the alpha 

emitters in the source matrix. This file is not always generated. 

The data is of the form x,y,r,z per row. Where r = 

Sqrt(x^2+y^2); 

  result.phd - Same as results.dat but in phd format. 

  tracking.dat 
- A generated file that contains paths of electrons. This file is 

not always generated. The data is of form energy,x,y,z per row. 
 

When coincidences are enabled and the coincidence output file will have the following 

format: 

 
Column Name Description 

1 Elib Line energy (library value) keV of 

peak. 

2 Ehigh Width of the coincidence box in keV 

3 RelHt Relative number of counts in 

coincidence box wrt. the peak. 

 

Example: 
 %Elib             Ehigh         RelHt 

    5485.560       10.00000      1.1349183E-02 

   5485.560       20.00000      3.2852896E-02 

    5485.560       30.00000      4.7786031E-03 

    5485.560       40.00000      3.2852896E-02 

 

Rows starting with „%‟ symbol are comments. 
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When alpha particle tracking is enabled the outputfile tracking.dat will have the following 

format: 
Column Name Description 

1 Energy Energy of the particle in keV 

2 X X-coordinate of the particle 

3 Y Y-coordinate of the particle 

4 Z Z-coordinate of the particle 

 

Example: 

 
 3.4859    0.0000    0.0000    0.5733 

    3.3821    0.0300   -0.0248    0.5846 

 3.3744    0.1195   -0.1377    0.6442 

 3.2674    0.1267   -0.1450    0.6489 

 3.1210    0.2361   -0.2194    0.7334 

 3.1184    0.3095   -0.2544    0.9268 

 3.0994    0.3110   -0.2545    0.9302 

 3.0821    0.3247   -0.2556    0.9526 

 2.9557    0.3385   -0.2519    0.9718 

 2.9028    0.0000    0.0000    0.0000 

 

Each successive row is a point on a trajectory. A new trajectory begins when the energy value 

of a row exceeds that of the preceding row. 

 



 58 

6. MENU REFERENCE 

6.1. Main window menus 

The 'File' menu 

File → Open input & detector Opens an AASI input file and the detector file associated 

with that input file. You will be prompted to select the 

desired file and the simulation state will then be set to be 

that of the selected input file. 

 

 

File → Save input Saves the current state of the simulation as an AASI input 

file. Note that this does not save the detector.  

File → Save input as... Saves the current state of the simulation as an AASI input 

file. You will be prompted for the filename. Note that this 

does not save the detector. 

File → Save detector Saves the current state of the detector as an AASI detector 

file. Note that this does not save rest of the input parameters. 

File → Save input as... Saves the current state of the detector as an AASI detector 

file. You will be prompted for a file name. Note that this 

does not save rest of the input parameters. The detector file 

saved will be the one used by the input. 

File → Exit Quits the program. Any unsaved changes will be lost! 

The 'View' menu 

View → Sketch window Toggles the sketch window visible. The sketch window 

provides visual cues to the measurement setup. 

View → Log window Toggles the log window visible. The log window provides a 

log of the output from the simulation code.  

View → Notes window Toggles the notes window visible. The notes window 

displays user provided notes about the current input file. 

View → Look & Feel This submenu contains a variable number of entries. The 

look and feel of the program is automatically determined at 

startup based on the operating system used. However 

extensive testing on every OS is practically impossible, so 

this option is provided should there be problems with the 

appearance of the program. The contents of this submenu 

depend on the Look And Feels installed on your system. The 

'Metal' one should provide unified cross-platform L&F. 

View → Simulation info browser The simulation info window displays more advanced 

information about the last simulation run.  
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The 'Run' menu 

Run → Run simulation Runs the simulation with the current state of the simulation 

options and parameters. For further information see section 

3.5.1.2 Running the simulation using the run menu 

Run → Run geometric efficiency 

calculation 

Displays the geometric efficiency calculation window 

allowing you to calculate the geometric efficiency. For 

more information see section 3.5.2.2 Calculating geometric 

efficiency using the run menu 

The 'Window' menu 

Window → Tile Tiles all visible windows on the current page. 

Window → Cascade Cascades all visible windows on the current page. 

Window → Minimize all Minimizes all windows on the current page 

Window → Maximize all Maximizes all windows on the current page 

The 'Help' menu 

Help → Help Displays the help browser 

Help → Show the welcome screen Displays the welcome page. 

Help → About... 
Displays the about box with version information and credits. 

 

6.2. Simulation plot window menus 

The 'File' menu 

File → Open… Opens a spectrum from a file. The opened spectrum will be added into 

the plot.  

 

Note that when opening a .fig format file, all the existing graphs and 

annotations will be deleted! 

File → Save currently 

selected graph 
Saves the currently selected graph to disk.  

File → Save plot as 

figure... 
Saves all the graphs in the plot window as a figure.  

File → Print.. Prints the plot. 

File → Page setup & 

preview... 

Lets you control the page orientation, scaling and other options for 

printing. 

The 'Edit' menu 

Edit → Copy selected graph in 

Excel format 

Copies the currently selected graph to the clipboard as an Excel 

format table with two columns: first one with energies and the 

second one with corresponding number of counts. The clipboard 

contents can then be pasted into Excel. 
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Edit → Copy selected graph in 

Matlab format 

Copies the currently selected graph to the clipboard as a Matlab 

format vector with two columns: first one with energies and the 

second one with corresponding number of counts. The clipboard 

contents can then be pasted into the Matlab command window. 

The 'View' menu 

View → Show properties pane Lets you show / hide the properties pane in the right edge 

of the simulation plot window. 

View → Show toolbar Lets you show / hide the toolbar at the bottom of the 

simulation plot window. 

The 'Zoom' menu 

Zoom → Zoom all Modifies the plot range so that the whole extents of all 

graphs are visible. 

Zoom → Zoom in Zooms in on the x-axis 

Zoom → Zoom out Zooms out on the x-axis 

Zoom → Pan right Pans the view to the right. 

Zoom → Pan left Pans the view to the left. 

The 'Graphs’ menu 

Graphs → Remove all graphs Removes all graphs from the plot. 

Graphs → Remove currently selected 

graph 

Removes the currently selected graph from the plot 

Graphs → Bring currently selected 

graph to the front 

Brings the currently selected graph to the front, causing the 

selected graph to be drawn on top of other graphs 

Graphs → Send currently selected 

graph to the back 

Sends the currently selected graph to the back, causing all 

other graphs to be drawn on top of the selected graph 

Graphs → Select next graph Causes the next graph to be set as the currently selected 

graph. Can be used to cycle through the graphs in the plot. 

Graphs → Select previous graph Causes the previous graph to be set as the currently 

selected graph. Can be used to cycle through the graphs in 

the plot. 

The 'Annotations' menu 

Annotations →  Add text Adds a text annotation. Point the mouse to where you want 

the text placed and left click to place the text. 

Annotations →  Add line Adds a line annotation. Point the mouse to where you want 

the annotation to begin and left click and drag to place the 

annotation. 

Annotations →  Add text tag Adds a text tag annotation. Point the mouse to where you 

want the text tag placed and left click to place the text tag. 

Annotations →  Add line tag Adds a line annotation. Point the mouse to where you want 

the line tag to begin and left click and drag to define the 

line tag. 
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Annotations →  Remove selected 

annotation 

Removes the currently selected annotation 

Annotations →  Remove all 

annotations 

Removes all annotations from the plot. 

 




